No power to the motor? PAS not working?

This is no doubt the most frustrating problem to have. Oftentimes on arrival after assembly and 1st rides, wires/connections shake loose in transit. Don’t worry, we will resolve this together with some troubleshooting by:

Clear inspection pictures always expedites the resolution.

Section 1: Advanced troubleshooting (If possible)
Section 2: Questions (expedites understanding and resolution)
Section 3: Reset display
Section 4: Inspect external wires and connections 
Section 5: Inspect internal wires and connections


Section 1: If you can access a 2nd 36V ebike you can sometimes expedite the resolution with Advanced Ebike Troubleshooting:

  • Do you own 2 ebikes?
  • Does your local bikeshop have ebikes? (bikeshops with ebikes commonly test some components this way, it may be faster to do some basic troubleshooting as described below, before taking yours into the shop) 
  • Do you know anyone with an ebike? (it is even worth asking your friends on facebook as it can save a lot of time)


Section 2: Questions

Error codes are very helpful in expediting the resolution. They may only be on screen briefly when the incident happens though the motor may remain non-functioning.

  1. Is there an error code on the the Display?  (04, 05, 07, 08, 09, 11, 12, 13, 14, 21, 22, or 30 will be displayed temporarily or stay on screen) 
  2. Did anything recently happen that may be related to the issue?
  3. Did you recently change settings in the display? (if yes, please explain)
  4. Did you recently remove the rear tire? (if yes, please explain)
  5. Did you recently disconnect any cables? (if yes, please explain)
  6. Did you drop, crash, or hit something with the bike? (if yes, please explain) Even if you barely hit something, a curb, a car mirror, etc. It could help us identify the cause.
  7. Did you continue to use PAS after stalling out on a hill or coming to a complete stop? (if yes, please explain)


TROUBLESHOOTING STEPS


Section 3. Does your display power on?

Try resetting your display settings to the factory default using the instructions below. Then test the PAS again.

  • Turn on your display. 
  • Within 10 seconds press and hold the M button for 3 seconds. 
  • This will access the settings of the display. 
  • Scroll to highlight Reset. 
  • Press the M button to select. 
  • Highlight "yes" and hit the M button again to reset to factory defaults.

Inspect External Cables, Wires, Connections

Section 4. Check all exterior cables, for fastest resolution, please share clear pictures

All connectors must be properly aligned before reconnecting to avoid damage.

Carefully disconnect, inspect both ends, share clear pictures. If any pins are bent or damaged, this could be the issueThen test the PAS again.

Zone 1 circled in red above:

Please share pictures - remove the rubber cover, inspect the wire for damage on all sides and send pictures of this area. The wire from the motor as it exits the axle of the rear wheel needs to be checked for damage on all sides.



Zone 2 circled in red above:

Please share a picture of this connection. The chainstay (near the rear wheel) has a 9-pin motor cable connector, it has arrows for alignment and should be firmly seated. You can carefully disconnect it and check the pins. Then carefully align it and make sure it is fully seated.

Zone 3 circled in red above:

Please share picture - This area needs to be inspected for damage. If the wire is not properly routed the tire could rub against the motor wire/cable or brake cable and damage it beyond repair.



Zone 4 circled in red above:

Please share picture -This area is where the motor wire enters the frame and should be checked for damage.

Zone 5 circled in red above:

With the bike OFF - Please disconnect and share pictures of each both sides of this connection (green plug shown below). 
Please also inspect the wire as much as possible as it enters the frame (do not pull it from the frame, but inspect what can easily/gently be slid out) 

Carefully align the arrows and reconnect it if no issues are present. 

Zone 6 circled in red above:

Wires at handlebars as they connect to the throttle, display and brakes. They should not be stressed or pulled tight as you turn the handle bars left and right.You can inspect each wire as it leaves the component for signs of stress or damage. If they become tight as your turn the handlebars, it is likely you could improve your cable/wire routing.



Section 5. The Roadster V2 internal wires and controller: Carefully removing the 2 bolts on the very bottom of the down tube, 1 on each side. 

~Make sure the correct size and type of bit is used to avoid damaging or stripping the bolts. 

~Never force screws, if it does not go in easily, something may be misaligned or in the way and forcing it will likely break something or cause permanent damage.


  1. Once the plate is removed, Very carefully and without forcing anything you can gently pull the wires out. Then slide the controller out. Now you can inspect the wires and connections.
  2. Check all internal cables, ensure all connections are secured and no cables are crushed, discolored, crimped, or torn. Carefully disconnect, inspect both ends for bent pins or damage, properly align and carefully reconnect. Be sure to also inspect the length of the wire.
  3. Please take and send pictures of each end with the wires disconnected. If the Ride1UP support team has pictures of each, this can expedite the resolution. 
  4. You may want to wait until we can review your pictures before putting everything back. However, if you found a loose connection and fixed it, that was likely the cause.


    1. Yellow/grey plastic connector connects controller to battery
    2. Green higo connector connects display to controller - 5 pins, should not be bent, needs to be aligned carefully before connecting
    3. Blue or other color bullet style connectors, possibly also grey/yellow - connects charging port to battery.
    4. Yellow higo connector connects cadence sensor to controller 3 pins, should not be bent, needs to be aligned carefully before connecting
    5. 9-pin motor cable connects to motor by chain stay

Once all connections have been checked, carefully put everything back. Do not force screws. If you have to force something, it is likely not aligned and will cause damage to something. Once everything is back together, carefully test the pedal assist to see if either are working.